Downloading and installing Node.js and npm

要在公共npm注册表或您公司的npm Enterprise注册表中发布和安装软件包,必须使用Node版本管理器或Node安装程序安装Node.js和npm命令行界面. 我们强烈建议使用Node版本管理器来安装Node.js和npm. 我们不建议使用Node安装程序,因为Node安装过程会将npm安装在具有本地权限的目录中,并且在全局运行npm软件包时可能导致权限错误.

注意: npm Enterprise需要npm 4.4.x或更高版本. 要下载最新版本的npm,请在命令行上运行以下命令:

[sudo] npm install npm -g

Overview

Checking your version of npm and Node.js

要查看是否已经安装了Node.js和npm并检查已安装的版本,请运行以下命令:

node -v
npm -v

Using a Node version manager to install Node.js and npm

节点版本管理器允许您在系统上的Node.js和npm的多个版本之间安装和切换,因此您可以在npm的多个版本上测试应用程序,以确保它们适用于不同版本的用户.

OSX or Linux Node version managers

Windows Node version managers

Using a Node installer to install Node.js and npm

如果无法使用Node版本管理器,则可以使用Node安装程序在系统上安装Node.js和npm.

OS X or Windows Node installers

如果您使用的是OS X或Windows,请使用Node.js下载页面中的安装程序之一. 确保安装标有LTS的版本. 其他版本尚未通过npm测试.

Linux or other operating systems Node installers

如果您使用的是Linux或其他操作系统,请使用以下安装程序之一:

或查看此页面以许多Linux开发人员喜欢的方式为Linux安装npm.

Less-common operating systems

有关在各种操作系统上安装Node.js的更多信息,请参阅本页 .


< About npm CLI versions | Configuring your registry settings as an npm Enterprise user >

by  ICOPY.SITE