npm-update Update a package

SYNOPSIS

npm update [-g] [<pkg>...]

aliases: up, upgrade

DESCRIPTION

该命令会将所有列出的软件包更新到最新版本(由tag config指定),同时注意使用semver.

它还将安装缺少的软件包. 与所有安装软件包的命令一样,-- --dev标志也将导致处理devDependencies .

如果指定了-g标志,则此命令将更新全局安装的软件包.

如果未指定软件包名称,则将更新指定位置(全局或本地)中的所有软件包.

[email protected]npm update将仅检查顶级软件包. 以前版本的npm也将递归检查所有依赖项. 要获取旧行为,请使用npm --depth 9999 update .

[email protected]npm update将更改package.json以将新版本保存为所需的最低依赖关系. 要获得旧的行为,请使用npm update --no-save .

EXAMPLES

重要版本注意:这些示例假定为[email protected]或更高版本. 对于较旧的npm版本,必须指定--depth 0才能获得下面描述的行为.

对于下面的示例,假定当前程序包是app并且它依赖于依赖项dep1dep2等). dep1的发行版本是:

{
  "dist-tags": { "latest": "1.2.2" },
  "versions": [
    "1.2.2",
    "1.2.1",
    "1.2.0",
    "1.1.2",
    "1.1.1",
    "1.0.0",
    "0.4.1",
    "0.4.0",
    "0.2.0"
  ]
}

Caret Dependencies

If app’s package.json contains:

"dependencies": {
  "dep1": "^1.1.1"
}

然后npm update将安装[email protected] ,因为1.2.2latest并且1.2.2满足^1.1.1 .

Tilde Dependencies

但是,如果apppackage.json包含:

"dependencies": {
  "dep1": "~1.1.1"
}

在这种情况下,运行npm update将安装[email protected] . 即使latest标记指向1.2.2 ,此版本也不满足~1.1.1 ,这等效于>=1.1.1 <1.2.0 . 因此,使用满足~1.1.1的最高排序版本,即1.1.2 .

Caret Dependencies below 1.0.0

假设app1.0.0以下的版本具有插入符号依赖性,例如:

"dependencies": {
  "dep1": "^0.2.0"
}

npm update将安装[email protected] ,因为没有其他满足^0.2.0版本.

如果依赖于^0.4.0

"dependencies": {
  "dep1": "^0.4.0"
}

然后npm update将安装[email protected] ,因为它是满足^0.4.0>= 0.4.0 <0.5.0 )的最高排序版本.

Updating Globally-Installed Packages

npm update -g会将update操作应用于每个已outdated已全局安装的软件包-即,其版本不同于latest .

注意:如果软件包已升级到比latest的版本,它将降级 .

SEE ALSO


by  ICOPY.SITE